I installed Visual Studio 2013 Professional as a Trial version while waiting for my company to complete the license purchase.

They completed the purchase of 4 licenses (64 bit), but were not given Product Keys. Instead, there is a particular .iso file with the license or product key embedded in some way.

I want to avoid having to uninstall Visual Studio 2013 only to reinstall Visual Studio 2013 and re-setup all my settings. Is this possible? Is there a way to extract the license/product key from the .iso or from other coworkers desktops that did a clean install?

Here is what I have tried (with 2 coworker installations):

  1. Looking for the license info in:

    HKLM\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\12.0\Licenses\*

    but it is unique on both computers.

  2. Looking for the Product Key in:

    HKLM\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\12.0\Registration\2000.0x0000\PIDKEY

    One install had one, which my install said was invalid when attempting to use it. The other install had a blank PIDKEY.

  3. Looking inside SW_DVD5_Visual_Studio_Pro_2013_English_MLF_X19-20996.ISO but I see no mention of a License or Product Key.

  4. Checking their Help > Register Product in Visual Studio, which simply says

    License: Product key applied

  5. Tried doing an install/repair from the ISO but it says:

    The product version that you are trying to set up is earlier than the version already installed on this computer.

    Likely because of the Visual Studio 2013 Update 1 and 2

Again, I would really like to avoid the multi-hour process of reinstalling VS 2013. Is there any way?

share
    
Don't think there is a way to get the license key but if you just install the ISO it should just update your trial version and leave all your settings and other tools/installs intact. Should take less than hour. – Scott Wylie May 20 '14 at 22:58
    
@ScottWylie tried that, but didn't work because of new service packs. updated question to not repeat here – arserbin3 May 21 '14 at 21:12
    
I'm voting to close this question as off-topic because it is not about programming as defined within the scope of the Help Center. This question should be addressed by Microsoft Support. – TylerH Feb 10 '16 at 22:06
    
This should be migrated to SuperUser. – Somnath Muluk Aug 24 '16 at 8:06
up vote 37 down vote accepted

I solved this, without having to completely reinstall Visual Studio 2013.

For those who may come across this in the future, the following steps worked for me:

  1. Run the ISO (or vs_professional.exe).
  2. If you get the error below, you need to update the Windows Registry to trick the installer into thinking you still have the base version. If you don't get this error, skip to step 3 "The product version that you are trying to set up is earlier than the version already installed on this computer."

    • Click the link for 'examine the log file' and look near the bottom of the log, for this line: Detected related bundle ... operation: Downgrade

    • open regedit.exe and do an Edit > Find... for that GUID. In my case it was {6dff50d0-3bc3-4a92-b724-bf6d6a99de4f}. This was found in:

      HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall{6dff50d0-3bc3-4a92-b724-bf6d6a99de4f}

    • Edit the BundleVersion value and change it to a lower version. I changed mine from 12.0.21005.13 to 12.0.21000.13: BundleVersion for Visual Studio lower the version for BundleVersion

    • Exit the registry

  3. Run the ISO (or vs_professional.exe) again. If it has a repair button like the image below, you can skip to step 4.

    Visual Studio Repair button

    • Otherwise you have to let the installer fix the registry. I did this by "installing" at least one feature, even though I think I already had all features (they were not detected). This took about 20 minutes.
  4. Run the ISO (or vs_professional.exe) again. This time repair should be visible.

  5. Click Repair and let it update your installation and apply its embedded license key. This took about 20 minutes.


Now when you run Visual Studio 2013, it should indicate that a license key was applied, under Help > Register Product:

License: Product key applied

Hope this helps somebody in the future!

Reference blog 'story'

share
1  
it took 4 hours for repair to complete and solved nothing, however registering a product with newly created Microsoft account extended my licence for additional 74 days :) – codekiddy Feb 20 '15 at 18:54
    
Had this exact issue after VS15 SP 1 RC broke my installation. Your fix worked great (regedit) – Thomas Hagström Nov 26 '15 at 8:01

protected by Bhargav Rao Jan 10 '16 at 21:40

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.